Monday, July 16, 2007

WordPress is a Bit Hooped

Since the upgrade to Etch, WordPress is a bit hooped. All the uploaded content (themes, plugins, images) were being stored under /usr/share which was not being backed up, so all that is gone. Also, it seems that when you login, you get the "upgrade your wordpress database" prompt and it gets a bit messed up. Images (and the images are there anyhow) and Pages show up as blog posts instead (crappy). And the themes seem to be totally broken. And we don't have any links.

It would seems that WordPress's bastard combination of database and file-based storage has gone a little haywire.

Yikes!

Saturday, January 20, 2007

Nibble Logo

The topic of the "official" nibble logo came up recently and Dante managed to find one. I can't remember if it's saved somewhere. Anyhow, I just found one as well, and this is the one I remember and I really dig it:

Nibble Logo

Looks nice, n'est ce pas?

I vaguely remember a few more. Something with a circle, I don't know. Anyone else got good ones from "the long long ago" or else good suggestions for a new one?

Monday, January 15, 2007

It's Officially a Love-Hate Relationship

It is now officially a love-hate relationship with WordPress and the home page for the Nibble.

Love in that I just figured out that the Joomla site has been completely abandoned. I have just updated the Apache config to redirect the main pages (www.nibble.bz and nibble.bz) to blog.nibble.bz. The nibble is going with WordPress in sickness and in health.

And on the hate (slash sickness) side, WordPress is really screwing up the RSS feeds. There was some fancy trick being used such that sites like FeedBurner could ask if there were updates to the page rather then fetch the whole page right away. It turns out that was too fancy. It broke all the RSS stuff (so far as we could tell). The fix is discussed here, basically you just comment out the "conditional get" crap which doesn't work. So now the feeds are working... Well rather, they're working fine for excessory but not me. Well, they're kindof working. Ugh, this bug will be fixed in an upcoming release, I'm sure.